开发经验

当前位置:首页>新闻中心>开发经验
全部 7 公司动态 2 行业动态 3 开发经验 2

宝塔面板php扩展SWOOLE无法安装,提示SWOOLEC Loader ext not installed

时间:2020-02-05   访问量:1427

检测PHP环境

一、前往http://www.swoole-cloud.com/trial/download/下载swoole-compiler-loader.php文件放置网站根目录,点我下载

二、浏览器访问网站/swoole-compiler-loader.php检测;

安装和配置Swoole Loader

一、根据以上检测结果下载对应文件,我这里是php7.1版本故下载对应的swoole_loader.so文件;

二、将刚才下载的Swoole Loader扩展文件(swoole_loader.dll或swoole_loader.so)上传到当前PHP的扩展安装目录中:/www/server/php/71/lib/php/extensions/no-debug-non-zts-20160303,目录可能有所不同需自检;

修改php.ini配置

编辑此PHP配置文件:/www/server/php/71/etc/php.ini,在此文件底部结尾处加入如下配置:

  1. extension=swoole_loader.so

注意:需要名称和刚才上传到当前PHP的扩展安装目录中的文件名一致

重启PHP服务

重启或重载PHP配置,宝塔需在软件管理-PHP设置-PHP配置重启或重载配置即可


上一篇:destoon7.0系统后台一直提示“请填写验证码”的解决方案

下一篇:没有了!

发表评论:

评论记录:

未查询到任何数据!

在线咨询

点击这里给我发消息 售前咨询专员

点击这里给我发消息 售后服务专员

在线咨询

免费通话

24小时免费咨询

请输入您的联系电话,座机请加区号

免费通话

微信扫一扫

微信联系
返回顶部